We are observing Google's services have begun to recover. We are still actively monitoring the situation.
Posted Jun 12, 2025 - 19:25 UTC
Identified
The issue has been identified as a widespread outage in Google Cloud.
Posted Jun 12, 2025 - 18:45 UTC
Update
It appears that there is a widespread issue with Google Cloud Platform that is not being reported by Google. Firezone's infrastructure is currently unaffected, but internal company operations are severely degraded.
We are currently investigating an issue with our Google account. This issue is not currently affecting Firezone's production infrastructure at this time.
Posted Jun 12, 2025 - 18:28 UTC
This incident affected: Google Cloud Platform Google Cloud DNS, Google Cloud Platform Google Cloud Networking, Google Cloud Platform Google Cloud SQL, Google Cloud Platform Google Cloud Storage, and Google Cloud Platform Google Compute Engine.